WalkMe's New Multi-Browser Editor

Once downloaded, please run the setup file and follow the instructions.

Please note, this extension requires the latest version of Chrome or Internet Explorer, installed on your machine.

If you encounter any issues during or after installation please contact WalkMe’s support at http://support.walkme.com

Advertisement